summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 1 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8c024e7..e09b0e1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "pollex"
-version = "0.4.0"
+version = "0.5.0"
authors = ["Gabriel Bjørnager Jensen"]
edition = "2021"
description = "Arm instruction manipulator."
@@ -18,7 +18,6 @@ bool_to_int_with_if = "warn"
borrow_as_ptr = "forbid"
branches_sharing_code = "warn"
cast_lossless = "warn"
-cast_possible_wrap = "warn"
cast_ptr_alignment = "forbid"
checked_conversions = "warn"
clear_with_drain = "warn"
@@ -101,7 +100,6 @@ option_as_ref_cloned = "warn"
option_if_let_else = "warn"
option_option = "deny"
or_fun_call = "deny"
-panic_in_result_fn = "deny"
path_buf_push_overwrite = "deny"
pattern_type_mismatch = "deny"
ptr_as_ptr = "forbid"