diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 13 |
1 files changed, 7 insertions, 6 deletions
@@ -4,22 +4,23 @@ pkgver=0.0.0 pkgrel=1 pkgdesc="GBA ROM header checksum patcher." arch=("any") -url="https://mandelbrot.dk/${pkgname}" -makedepends=("cmake" "git" "susinfo" "zap") -source=("git+https://mandelbrot.dk/${pkgname}") +url="https://mandelbrot.dk/agbsum" +makedepends=("cmake" "git") +source=("git+https://mandelbrot.dk/agbsum") license=("AGPL3") sha512sums=("SKIP") pkgver() { cd "${srcdir}/${pkgname}" - printf "%s.0.0" "$((0x$(git describe --abbrev=0)))" + printf "%s" "$(($(git describe --abbrev=0)))" } build() { cd "${srcdir}/${pkgname}" - cmake -Bbuild -DCMAKE_BUILD_TYPE="Release" -DCMAKE_GENERATOR="Unix Makefiles" - make -Cbuild -j$(($(nproc) + 0x1)) + cmake -Bbuild -DCMAKE_BUILD_TYPE=Release + cmake --build build } package() { cd "${srcdir}/${pkgname}" mkdir -pm755 "${pkgdir}/usr/bin" install -m755 "build/agbsum/agbsum" "${pkgdir}/usr/bin" } + |