summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..3840637
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "aas"
+version = "0.0.0"
+authors = ["Gabriel Bjørnager Jensen"]
+edition = "2021"
+description = "Arm assembler."
+repository = "https://mandelbrot.dk/aas"
+
+[[bin]]
+name = "aas"
+path = "src/aas.rs"
+
+[profile.release]
+codegen-units = 1
+lto = "fat"
+
+[dependencies]
+enum-iterator = "1.4.1"